User.toml not being picked up at /hab/user/{service}/config/user.toml


#1

Hi,

I am running hab 0.57.0/20180614230004 on Centos 7.4. I have a package called ‘compliance’ that I am trying to drop a user.toml for at /hab/user/compliance/config/user.toml. It was my understanding that any user.toml at that path will by automatically picked up by the supervisor, and that updates to that file will also be picked up. However, that is not what I am seeing. I still need to do a hab config apply to get that config picked up.


#2

That’s been my experience as well, going back at least a few versions of the supervisor. I’m not certain if that was changed on purpose of it it’s a bug. I’ve gone through the open habitat issues but I can’t find anything related to this.

@christophermaier is this something you know about?


#3

@smford22 are you starting the compliance service then creating the user.toml ?

Behavior that I’ve observed is modifying an existing user.toml will be picked up by the hab-sup, but if you start the compliance service, then drop a user.toml the supervisor doesn’t pick it up, I had to restart my service.

I haven’t validated that’s the user experience with 0.57, but I was seeing the same behavior in 0.55 and 0.56.


#4

Yeah this is a known bug at the moment. Effectively the new “canonical” path is the one that doesn’t work. I think it still works on the deprecated path of /hab/svc/<service_name>/user.toml.


#5

Sorry I’m late to the party… /hab/user/<service>/config/user.toml is indeed the path for user.toml that is watched for changes.

One thing to check is that you don’t have any config that’s being gossiped (e.g., using hab config apply) that would mask those changes, since they take priority over user.toml.