How does habitat select which launcher package to use?


#1

Also, is there a way to select a specific version of launcher to use?


#2

If a launcher package isn’t already present on the system (i.e., /hab/pkgs/core/hab-launcher doesn’t exist), then the latest stable package will be downloaded from Builder. This will then be used.

On the other hand, if one (or more) launcher packages have been installed locally, the latest one is used. So, if you had versions 1, 2, and 3 installed, version 3 would be used.

Thus, to control which version of the launcher is used, ensure that your desired version is installed prior to starting the Supervisor, and ensure that it is the most recent version on the system.