Having some trouble with core/dex


#1

Hello!

I’m having some issues with core/dex. I’m trying to build the plan as it is, then export it to docker (for demo/testing purposes, not production usage). I noticed that the default value for service.port is 5556.

How I’m attempting to run this is:

$ git clone http://github.com/habitat-sh/core-plans
$ cd core-plans/dex
$ hab studio enter
(studio) $ build
(studio) $ hab pkg export docker ./results/<latest_build.hart>
(studio) $ exit
$ docker run -it -p 5556:5556 core/dex

The docker container appears to work find, however when I attempt to hit http://localhost:5556 in my browser, it returns with “404 Not Found” - is there an alternate url I should be navigating to to see this working?


#2

Try these:

I followed your steps, and these seem to work for me. :slight_smile:


#3

+1, what @cnunciato said, as a first approximation. To see something more, you could use the example-app it ships (not core/dex, but the upstream project, via github.com/coreos/dex/cmd/example-app). to actually login, you’d need a client (example-app) and a (static) user set up in config.yml, along those lines:

staticClients:
- id: example-app
  redirectURIs:
  - 'http://127.0.0.1:5555/callback'
  name: 'Example App'
  secret: ZXhhbXBsZS1hcHAtc2VjcmV0
enablePasswordDB: true
staticPasswords:
- email: "admin@example.com"
  # bcrypt hash of the string "password"
  hash: "$2a$10$2b2cU8CPhOTaGrs1HRQuAueS7JTT5ZHsHSzYiFPm1leZck7Mc8T4W"
  username: "admin"
  userID: "08a8684b-db88-4b73-90a9-3cd1661f5466"

The important thing is that you’re using issuer-url consistently. example-app's defaults however, should match dex’s defaults in most ways.

HTH :slight_smile:


#4

Thank you, you two! It is much appreciated!