403 error working though learn chef track


#1

I’m working through the Learn Chef habitat track (https://learn.chef.io/modules/try-habitat#/), and getting the following error, can anyone help in debugging what’s going on?

[12][default:/src:1]# build haproxy
   : Loading /src/haproxy/plan.sh
   haproxy: Plan loaded
   haproxy: Validating plan metadata
   haproxy: Using HAB_BIN=/hab/pkgs/core/hab/0.59.0/20180712155441/bin/hab for installs, signing, and hashing
   haproxy: hab-plan-build setup
   haproxy: Writing pre_build file
   haproxy: Resolving build dependencies
   haproxy: Resolving run dependencies
» Installing core/haproxy
☁ Determining latest version of core/haproxy in the 'stable' channel
✗✗✗
✗✗✗ [403 Forbidden]
✗✗✗
   haproxy: WARN Could not find a suitable installed package for 'core/haproxy'
ERROR: Resolving 'core/haproxy' failed, should this be built first?
   haproxy: Build time: 0m2s
   haproxy: Exiting on error

#2

Is this behavior consistent? It’s possible to get the 403 if the builder API is down. It had a brief blip during a new release on Thursday, but it appears to be fine now.

I’m able to successfully install core/haproxy, so it’s not an issue of a missing package on Builder. If there were something wrong with your setup (from running hab setup), that could be causing issues. Can you try the following?

  1. Start with a clean studio by running hab studio rm outside the studio in the directory you cloned hab-two-tier.git into.
  2. Remove any existing artifacts by running rm -r results in that same directory.
  3. hab studio enter and retry the build with RUST_LOG=debug build haproxy to include extra diagnostic info.

Please include the entire output from the point of entering the studio. Some configuration errors will show up then, rather during the build command.


#3

Thanks, that helped and showed me I was using the wrong key in HAB_AUTH_TOKEN. I was using the signing token key not the access key.